SMS Text message do not appear in order, have incorrect time stamps.

Thu Dec 08, 2011 3:18 am in AirDroid Web

page 1 / 3 << 1, 2, 3 >> go to
A_Moose
OP

SMS Text message do not appear in order, have incorrect time stamps.

Verizon Motorola Droid X2
Gingerbread 2.3.4

Able to send and receive text message through AirDroid. The time stamps on messages received seem to always be wrong. This causes the conversation to appear out of order. Whenever a message is received, they seem to just appear after the previously-received message. The date on messages appear to be correct.

It would also be cool if the page could refresh after a message is received, so that I didn't have to refresh it myself after I hear the message tone.
A_Moose
Bobert
#1

Title

I'm seeing this now as well. The incoming messages appear to be 5 hours behind so they always show up out of order.

I'm currently in Eastern time, so the only thing 5 hours behind is Hawaii.
Bobert
LuxRunner
#2

Title

I am seeing the same as both users above. Mine is 6 hours behind. I'm on mountain time.
LuxRunner
nasatome
#3

Title

Droid RAZR... same issue, but time stamps jump around. In a 15 minute text exchange, the hour actually jumped backwards (the first couple responses showed 5 hours behind, then the next few showed 6 hours behind). The minutes are consistent, though.
nasatome
xaptwo
#4

Title

seeing the same thing... really makes it unusable when the other person's messages are 8 hours behind mine according to the time stamps. thought this was supposed to be resolved according to the latest update on the market.
xaptwo
airdroidAdmin Admin
#5

Title

Looking into this issue now. Thanks :)
airdroidAdmin
Admin
Kia_SX
#6

Title

I'm having this same issue but my texts are listing 8 hours behind.
Droid X
Froyo

Mac OSX 10.7.2
Chrome 16.0.912.63
Kia_SX
Bobert
#7

Title

I just noticed in the "unified inbox" the messages are also showing as being 5 hours behind, even though they show up fine in the sms app itself. This is obviously related somehow but I will be damned if I know how. :-)

I'm trying the sms fix app now to see if that helps with future incoming messages
Bobert
megsdkck2trt
#8

Title

Droid Razr
2.3.5

I dont believe its the app...I've tried a few remote SMS apps over the last week which all are doing the same thing. I've disabled automatic time updates on the phone w/ the correct time zone selected. No change.

Its been a while since I looked at the SMS database, but i'm pretty confident all the time stamps are GMT. Seems as though its pulling the time stamp but not applying the local offset for the remote messages.
megsdkck2trt
Bobert
#9

Title

Actually it seems like it's applying it twice when you think about it.
The messages in the store are in GMT, but the SMS app applies the local offset, so they show up with the right time.

But apparently when AirDroid opens them to display them, they already have the offset applied, and the app applies it *again*, hence they show up with GMT-[whatever your local offset].

In my case they show up -5 since I'm in the East coast. I'd imagine the people on the West coast see it as -8, etc.

Could be the way the phone is presenting the SMS db to the app. I know after I followed Ryan's suggestion and installed the SMS Time Fix, the issue seems to have gone away. I can't check all my conversations however since I'm still suffering from the "minimized SMS window" bug as well in some cases. :)
Bobert
(Sign in or sign up to post a reply.)
page 1 / 3 << 1, 2, 3 >> go to

Statistics

22663 posts

6166 threads

Members: 146816

Latest Member: wati

Online: 5