Trouble connecting device to website

Thu May 31, 2012 12:46 am in AirDroid Web

page 3 / 3 << 1, 2, 3 >> go to


Same problem here. It used to work and now it doesn't. I'm using HTC Sensation and XP on a laptop.
It doesn't matter which order I launch the app/open and try to connect, I still get "Failed to connect. Make sure your device is connected to a same WiFi network." I've tried uninstalling and reinstalling the app, but no joy.

The link a couple of posts above is for a beta test that you have to be invited to and download a .apk file sent to beta testers by email.

It still works if connect my laptop to the internet via my phone's wi-fi hotspot, but that's not what I want.


I had the same issue on 3 devices
LG Phone
Samsung Phone
Android x86 on Acer Aspire.
The "Cloud Status" was showing that the Push Service was disconnected.

What i did to overcome this?
a) Clear Data
b) Clear cache
After that, the app just asked me to login (Data cleared -> db cleared -> username/passwd cleared ;-) )
and then everything working fine again.



I just fixed my issue with this app. You need to make sure AIRDROID APP is UP TO DATE. Just update mine to 2.0 and BAM....problem solved!
(Sign in or sign up to post a reply.)
page 3 / 3 << 1, 2, 3 >> go to


24655 posts

7416 threads

Members: 235408

Latest Member: ~Snatjon~

Online: 17