Consistently receiving corrupt zip files

Tue Nov 20, 2012 3:15 pm in AirDroid Web

page 1 / 1

Consistently receiving corrupt zip files

Three devices are receiving corrupt zips over and over again when downloading using Airdroid

Software Version:

Airdroid 1.1.0 (on all 3 devices below)


Galaxy Nexus (GSM) on Android 4.2 build JOP40C
Galaxy Nexus (CDMA) on Android 4.1.2 build JZ054K
Samsung Galaxy Tab 2 10.1 WiFi (GT-P5113) on Android 4.0.4 build IMM76D.P5113UEBLH3

This has happened when pulling on all of the following browsers and operating systems:

Windows 7 64 Bit running Mozilla Firefox (latest version)
Ubuntu 12.04 64 Bit running Mozilla Firefox (latest version in the repos)
Ubuntu 12.04 64 Bit running Google Chrome (latest version)

This has worked on both Ubuntu and Windows prior, not sure what the last working version is since I do not back up that often
I have also tried saving the zip to an external hard drive and extracting onto it from there as well and the zip is corrupt still
This happens every time without fail, the zip downloads flawlessly, but you cannot extract it
WINRAR says the file is corrupt, File Roller (the app I'm using in Ubuntu) says a whole load of stuff but I'm not currently on there to copy/paste, but it essentially says there an an issue with the archive


Hi ,

I am new to AirDroid and I am trying to download my SD card from my Galaxy Nexus (Toro) on Verizon. It downloads the zip file fine, but when I go to open it I get a error message in WinRAR and 7zip that the file is corrupt. I have tried it in Google Chrome and IE and I am running Windows 7 as my computer. The version of Airdroid is from September 30, 2013.

What do I do to solve this?

Thanks for any help.
Harvey Stein

Re: Consistently receiving corrupt zip files

I'm also getting corrupt .zip files when downloading directories, but it seems to be related to the file size. This is when transferring from my Galaxy Nexus to a Linux box. Zip files over 4gb seem to always be corrupt and always in the same way. unzip -t shows:

warning []: 4294967296 extra bytes at beginning or within zipfile
(attempting to process anyway)
file #1: bad zipfile offset (local header sig): 4294967296
(attempting to re-compensate)
file #1778: bad zipfile offset (local header sig): 12166017
(attempting to re-compensate)

Is there an inherent limit on the size of the zip files that AirDroid produces? Does AirDroid use the Zip64 extensions?

Harvey Stein
(Sign in or sign up to post a reply.)
page 1 / 1


24655 posts

7416 threads

Members: 235540

Latest Member: ekam

Online: 55